What are the technical requirements for my computer in order to use Quercus? 

Below are the basic system and browser requirements to use Quercus. 

Operating Systems

  • Windows 7 and newer
  • Mac OSX 10.10 and newer
  • Linux - chromeOS

Computer Speed and Processor

  • Use a computer 5 years old or newer when possible
  • 1GB of RAM
  • 2GHz processor

 Internet Speed

  • Along with compatibility and web standards, Canvas has been carefully crafted to accommodate low bandwidth environments.
  • Minimum of 512kbps

Please visit this webpage for the most up-to-date list of basic computer system requirements. 

Supported Browsers

Canvas supports the current and first previous major releases of the following browsers. We recommend using either Chrome or Firefox for the best experience. Please visit this webpage for additional information about supported browsers:

  • Chrome 75 and 76
  • Firefox 67 and 68 (Extended Releases are not supported*)
  • Edge 44 (Windows only)
  • Respondus Lockdown Browser (supporting the latest system requirements)
  • Safari 11 and 12 (Macintosh only)

Internet Explorer is no longer supported as a Canvas browser.

You should always use the most current version of your preferred browser. Your browser will notify you if there is a new version available.

Was this article helpful?